Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Tout ce qui n'a pas de catégorie !
HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1371
Âge : 62
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#11 Message par Gérard » mar. 12 mars 2019 22:14

pspic a écrit :
Bonjour à tous,
Il fallait rester sous MikroBasic SetBit(PORTA,0)

Je sors .....



Je crois bien que tu as raison. :lol:
Ceci dit, mon module HC05 ne veut pas du PC. :mur:
J'ai essayé TeraTerm, Vbray et BlueSoleil et rien ne fonctionne. :furieux: :furieux:
Je crois bien que je porte la poisse ce soir.
Je vais me jeter dans les bras de Morphée.

Ci-dessus, un copié/collé d'ici
Je préfère continuer ici pour ne pas polluer l'autre fil.
Jérémy, si tu veux bien faire le ménage, merci d'avance.

Je vais essayé le programme Basic de pspic mais plus ce soir. Comme rien ne fonctionne, j'en ai assez pour aujourd'hui.
A bientôt pour la suite.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
venom
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 792
Âge : 35
Enregistré en : avril 2016
Localisation : Klyntar
Contact :

#12 Message par venom » mer. 13 mars 2019 07:03

Bonjour Gérard et bonjour a tous,

Arrive tu via un terminal a communiquer avec ton module ?

Logiquement si tu relie ton module a ton ordi avec un cordon USB/ttl comme sur cette photo ?

Une foi connecter au terminal envoie juste
AT+NAME
Normalement le module te répond et envoie son nom.
Essaye déjà de communiquer avec les commandes AT






@++
En fait tout est une question de BIT ? :-D

HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1371
Âge : 62
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#13 Message par Gérard » mer. 13 mars 2019 09:15

Ben non, le module ne répond rien. Il est bien connecté comme prévu.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1712
Âge : 70
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#14 Message par paulfjujo » mer. 13 mars 2019 11:45

bonjour Gerard,


attention aux differences entre HC05 et HC06 !
voir post#3

comment connectes-tu ton module au PC ?
via un cordon Prolific ou autre ?
est-ce un HC05 ?

le HC05 NE DOIT PAS ETRE APPAIRE
led clignotante

le HC05 demande un <CR><LF> en fin de commande
La 1ere commande à tester est
AT<CR><LF>
il doit repondre OK


sinon
faire d'autres test avec des vitesses differentes
9600,19200,57600, 115200 bauds !

une fois la reponse OK à la commande AT
on peut alors changer la vitesse
Aides toi, le ciel ou Fantastpic t'aideras

HC05 et HC06
pspic
Passioné
Passioné
Messages : 323
Âge : 73
Enregistré en : septembre 2017
Localisation : 68

#15 Message par pspic » mer. 13 mars 2019 11:46

Salut Gérard,
Tu es bien à 9800 bauds et sur le bon Port USB coté PC ?
Si tu envoi AT vers le HC06, il te répond OK si le branchement est bon.
Test_HC06.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1371
Âge : 62
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#16 Message par Gérard » mer. 13 mars 2019 11:59

Hello tous,
C'est cool votre dévouement, cet AM je continue les essais.
Et comme dans la pub "Je l'aurai un jour, je l'aurai". :lol: :lol:
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
pspic
Passioné
Passioné
Messages : 323
Âge : 73
Enregistré en : septembre 2017
Localisation : 68

#17 Message par pspic » mer. 13 mars 2019 12:48

Tu peux aussi vérifier avec l'application USBdeview si le module FTD est bien vu par le PC.
Tu télécharges USBdeview ici: https://www.malekal.com/usbdeview-gerer ... iques-usb/
Tu lances USBdeview et tu copies la liste des périphériques USB connectés au PC.
Tu fermes USBdeview.
Tu connectes le FTD + HC06 sur un connecteur USB du PC.
Tu lances USBdeview et tu cherches dans la liste l'adresse du port Com qui s'est ajouté.
Tu configures ton outil (Realtherm, ...) à ce port Com et à 9600 bauds.

Maintenant je suis un peu dans le brouillard avec ce que tu veux faire ?
Si c'est allumer et éteindre une Led, tu connectes le HC06 à l'easy Pic, et tu envois la commande avec ton smart phone.

HC05 et HC06
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1712
Âge : 70
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#18 Message par paulfjujo » mer. 13 mars 2019 13:13

il faudrait surtout savoir si on parles du HC05 ou du HC06

le HC06 ne veut pas de <CR> ou <LF> apres la commande AT
pour repondre OK
Aides toi, le ciel ou Fantastpic t'aideras

HC05 et HC06
pspic
Passioné
Passioné
Messages : 323
Âge : 73
Enregistré en : septembre 2017
Localisation : 68

#19 Message par pspic » mer. 13 mars 2019 14:35

paulfjujo a écrit :il faudrait surtout savoir si on parles du HC05 ou du HC06

le HC06 ne veut pas de <CR> ou <LF> apres la commande AT
pour repondre OK

Je parle de HC06 n'ayant pas de HC05 sous la main.
Sur la copie d'écran de Realterm (Pos #15) ni CR ni LF sont cochées et pourtant le HC06 répond OK.
Si je coche CR ou LF ou les deux, je n'ai plus de réponse.

HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1371
Âge : 62
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#20 Message par Gérard » mer. 13 mars 2019 15:07

[*]J'ai branché un 05 comme en #8 --> pas de réponse avec aucun soft.
J'ai branché un 06 comme en #15 --> pas de réponse.
Je vais téléchargé ce que dit pspic en #17

Bientôt :mur:
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.


Retourner vers « Coin Fourre-tout »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités