Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Idée, bugs, propositions .......
Installation de MPLABX XC8
Babar64
Avatar de l’utilisateur
Débutant
Débutant
Messages : 42
Âge : 72
Enregistré en : juillet 2021
Localisation : Sud-Ouest

#1 Message par Babar64 » lun. 28 mars 2022 20:29

Bonjour à tous,
J'ai installé MPLABX XC8 sous W10, à partir de "xc8-v2.36-full-install-windows-x64-installer.exe". A priori, tout s'est bien déroulé. Mais aucun raccourci de lancement... J'ai bien des répertoires "Microchip" dans C:\Programmes et C:\ProgramData, mais PAS dans C:\Programmes (X86)... J'ai redémarré le PC, au cas où, mais toujours pas de moyen pour lancer le pogramme... :mur: j'ai désinstallé, et réinstallé, sans plus de succès... Avez-vous déjà rencontré ce type de problème ? Toute aide bienvenue. Merci !
:idea: Pourquoi faire compliqué quand on peut faire inextricable

Installation de MPLABX XC8
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2155
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#2 Message par paulfjujo » lun. 28 mars 2022 21:02

bonsoir à tous,

Je pense qu'il faut d'abord installer MPLABX IDE
j'utilise la version MPLABX IDE 5.30
et XC8 version 2.32

attendre d'autres avis ...
Aides toi, le ciel ou FantasPic t'aideras

Installation de MPLABX XC8
satinas
Confirmé
Confirmé
Messages : 925
Enregistré en : novembre 2015

#3 Message par satinas » lun. 28 mars 2022 22:01

Bonsoir,

Itou, si tu ne fais pas d'assembleur tu peux installer la dernière version de MPLABX, puis celle de xc8. MPLABX, c'est l'environnement de développement qui permet d'éditer le programme, puis de lancer la compilation et la programmation du pic. L'installation doit se terminer par la création dans le menu démarrer des raccourcis qui vont bien.

Chez moi le raccourci MPLABX Win10-64 est :
"C:\Program Files\Microchip\MPLABX_0550\mplab_platform\bin\mplab_ide64.exe"

Installation de MPLABX XC8
Temps-x
Avatar de l’utilisateur
Expert
Expert
Messages : 2152
Enregistré en : juillet 2016
Localisation : Terre

#4 Message par Temps-x » mar. 29 mars 2022 01:46

Bonsoir Babar64, paulfjujo, satinas, et tout le forum,

En ce qui me concerne je ne peux pas t'aider car je suis sous Windows XP Professionnel, pack 3, de plus je pratique que ASM

idea ! mais ceux qui ont fait l’installation par défaut avec le même système d'exploitation que toi, et les même logiciel, doivent avoir le raccourci de l'icône de lancement rapide sur leur bureau, il suffit qu'il te les joindre en zip, puis tu l'es décompresse sur ton bureau, et ça devrait fonctionné.

Je pense que les icônes de lancement rapide doivent fonctionné même si le système d'exploitation sont différent, avec l'installation par défaut.

==> A+
:roll: Les requins, c'est comme le langage ASM, c'est le sommet de la chaîne alimentaire. :wink:

Installation de MPLABX XC8
Babar64
Avatar de l’utilisateur
Débutant
Débutant
Messages : 42
Âge : 72
Enregistré en : juillet 2021
Localisation : Sud-Ouest

#5 Message par Babar64 » mar. 29 mars 2022 22:07

Bonsoir à tous, et merci de vos réponses. Je n'ai pas pu récupérer la version MPLABX-v5.30 sur le site de Microchip, mais MPLABX-v6.00-windows-installer.exe... qui pèse 653Mo!
Sous W10 en 64bits, j'ai donc lancé l'installation sur le répertoire proposé par défaut : "Programmes (X86)" ; Puis j'ai lancé xc8-v2.36-full-install-windows-x64-installer.exe sur le même répertoire... NADA :mur: J'ai voulu tout désinstaller : pas de problème pour XC8, mais une vraie pagaille pour MPLABX dans User\ApplicationData\Roaming\Microchip\... J'ai finalement pu tout réinstaller, mais dans le répertoire : "Programmes" (sans X86).
Et là, le software s'est ouvert en fin d'installation, m'a balancé 4 messages d'erreur et demandé 6 mises à jours... Une fois terminées, un tout petit popup en bas d'écran m'a permis de redémarrer le programme, et ... :-D miracle! un raccourci de lancement est apparu sur mon bureau...
Sauf que... quand je le lance, j'ai une fenêtre MPLAB IPE 6.00 :?:, donc complètement différente de celle que j'avais eu à la fin de l'installation, avec en plus, des infos inquiétantes en bas d'écran : Tools :NA ; Environnement : NA ; Tool Pack Version : NA
... Bref, je ne m'en sors toujours pas... Merci de votre compassion!
:idea: Pourquoi faire compliqué quand on peut faire inextricable

Installation de MPLABX XC8
satinas
Confirmé
Confirmé
Messages : 925
Enregistré en : novembre 2015

#6 Message par satinas » mer. 30 mars 2022 04:26

Bonjour à tous
Depuis la 5.4 MPLABX IDE et IPE sont des exécutables 64 bits, il faut donc les mettre dans "C:\Programmes" comme proposé à l'installation. Idem pour xc8. Le raccourci pour lancer MPLABX IDE est le suivant :
"C:\Program Files\Microchip\MPLABX\v6.00\mplab_platform\bin\mplab_ide64.exe"
Bonne journée.
MPLABX 6.00_xc8.jpg
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Installation de MPLABX XC8
Babar64
Avatar de l’utilisateur
Débutant
Débutant
Messages : 42
Âge : 72
Enregistré en : juillet 2021
Localisation : Sud-Ouest

#7 Message par Babar64 » mer. 30 mars 2022 10:22

Bonjour à tous,
Je confirme : la nuit porte conseil...
satinas a écrit :il faut donc les mettre dans "C:\Programmes" comme proposé à l'installation

Oui et non. Sous mon W10 64bits (version 21H1-19043.1586), l''installateur n'a eu que faire du chemin proposé par défaut ou entré manuellement : il a finalement pu créer "son" répertoire "Programmes Files" sous C:\... C'est ça qu'il veut! J'ai donc bien maintenant des raccourcis qui fonctionnent :
-> IDE : "C:\Programmes Files\Microchip\mplab_platform\bin\mplab_ide64.exe"
-> IPE : "C:\Programmes Files\Microchip\mplab_platform\bin\mplab_ipe64.exe"
En revanche, toujours rien pour XC8... pour l'instant...
A+
:idea: Pourquoi faire compliqué quand on peut faire inextricable

Installation de MPLABX XC8
satinas
Confirmé
Confirmé
Messages : 925
Enregistré en : novembre 2015

#8 Message par satinas » mer. 30 mars 2022 10:39

Le dossier d'installation de MPLABX par défaut est ""C:\Program Files\Microchip\MPLABX\v6.00\". Il te manque la fin et ceci est un mystère, a moins que tu l'ai spécifié lors de l'installation.

Il faut donner plus de détails, sinon ça va durer très longtemps :)
Est-ce que MPLABX IDE démarre et affiche la même chose que mon image ci-dessus ?
Est-ce que XC8 est bien installé dans "C:\Program Files\Microchip\xc8" ?
Est-ce que la fenêtre "Tools/Options/Embedded/Build_Tools" affiche bien XC8 comme dans mon image ci-dessus ?

Installation de MPLABX XC8
Babar64
Avatar de l’utilisateur
Débutant
Débutant
Messages : 42
Âge : 72
Enregistré en : juillet 2021
Localisation : Sud-Ouest

#9 Message par Babar64 » mer. 30 mars 2022 12:20

Sauf erreur de ma part, en principe, sous W10, il n'y a pas de Programmes Files comme sous XP.
Les installations se font soit dans Programmes (X86) , soit dans Programmes. Pour une raison inconnue, MPLAB IDE veut un chemin "C:\Programmes Files", mais pas XC8 qui, lui, quoiqu'on indique comme chemin, s'installe de facto dans "C:\Programmes"... Je n'ai jamais vu ça.

satinas a écrit :Source du message Il te manque la fin et ceci est un mystère?

Je n'ai fait qu'accepter le chemin proposé à l'installation C:\Programmes Files.... C'est vrai que je n'ai pas tenté d'ajouter une suite quelconque

satinas a écrit :Source du message Est-ce que XC8 est bien installé dans "C:\Program Files\Microchip\xc8" ?

Non. Il s'est installé sous C:\Programmes\Microchip\xc8, alors que j'ai bien eu de proposé le chemin C:\Programmes Files, que j'ai accepté... Visiblement, cet installateur fait ce qu'il veut...

satinas a écrit :Source du message Est-ce que la fenêtre "Tools/Options/Embedded/Build_Tools" affiche bien XC8 comme dans mon image ci-dessus ?

Oui, et ça c'est plutôt bon signe, non ?
:idea: Pourquoi faire compliqué quand on peut faire inextricable

Installation de MPLABX XC8
satinas
Confirmé
Confirmé
Messages : 925
Enregistré en : novembre 2015

#10 Message par satinas » mer. 30 mars 2022 12:36

"Programmes" et "Program Files" c'est la même chose, la francisation de Windows est passée par là :)
J'ai pas fait attention, tu bloquais là dessus. Le dossier s'appelle "Program Files", et l'explorateur l'affiche sous le nom "Programmes". De la même façon, "Users" est devenu "Utilisateurs" dans l'explorateur.
Oui ça a l'air bon, branche un PicKit3, charge un projet xc8, ensuite il y a 2 icônes, "Run" ou "Debug".

PS: J'espère que tu n 'as pas créé un dossier "C:\Programmes", dans ce cas l'explorateur affichera 2 dossiers "C:\Programmes", le premier étant "Program Files" affiché en francisé, le second celui que tu as créé :-)
Et si tu as réellement créé un dossier "C:\Programmes Files" alors là, my god, au secours :)


Retourner vers « Le forum Fantas-PIC »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités