Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur l'Assembleur !

Modérateur : mazertoc

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#1 Message par Guigui02 » mar. 29 mai 2018 18:38

bonjour a tous cela fait bientot 15 jours que j'ai des problemes avec mon pickit 3 je precise que c'est un clone.
il me fait bugger le pic des fois il ne veux plus se connecter et maintenant il met met cette erreur :
PICkit 3 detected
Connecting to PICkit 3...
Firmware Suite Version...... 01.28.90
Firmware type......................Midrange
PICkit 3 Connected.
Target Detected
Target Device ID (00000000) does not match expected Device
ID (00001060).
je n'en peux plus ...
j'ai deja programmé avec ce pic ce schema enfin bref je n'ai rien changé mis a part le programme dans le pic . j'ai essayé de changer de pic sa refonctionne mais apres quelques programmation sa recommence qu'en epnnsais vous ?
peut on cramer un pic avec un programme qui ne serais pas bon ?
merci d'avance

pickit 3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1019
Âge : 67
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#2 Message par paulfjujo » mar. 29 mai 2018 20:07

bonsoir,

Peux-tu donner un peu plus de detail

schema de branchement
quel PIC
mode d'alimentation , tension ..

j'utilise aussi un clone PICKIT 3 W
testé sur 16F1847,12F1840,18F26K22, 46K22 .. sans probleme
en mode Pickit3 standalone
et avec MikroC.

la plupart du temps, je prefere alimenter le PIC via une alim externe , surtout si il y a d'autre devices connectes au PIC ( et donc sur l'alim VCC)
mais si le PIC est seul, l'alim VDD du pickit3 convient bien.

Nota: il vaut mieux isoler les pin ISCP DAT et ICSP CLOCK du PIC d'autres connections appartennat à l'application.
RB7 RB6 sur des 18F

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#3 Message par Guigui02 » mar. 29 mai 2018 20:59

Oups oui desolé j’ai ecrit ce message vite fait car j’etait un peu enervé lol.
Le pic c’est un 16f628A alim 5V externe pour le schema icsp j’ai Fait celui ci mais sans le condensateur C7 ni la diode D2
https://www.best-microcontroller-projec ... ng-led.png
J’ai mis un quartz 20mhz
Au debut mplab me disai que la cible n’etait pas alimenté car vdd sur le connecteur icsp ne detcté pas de tension alors je l’alimentais via le pickit et sa fonctinnais mais j’ai preferé envoyer le 5v direct sur le vdd du connecteur icsp comme sa je n’envoyé pas de tension via le pickit sa a fonctionné mais aleatoirement ...
J’ai un afficheur 7 segments de branché sur le port B et les 2 cathode des 2 digits sur RA0 et 1 ainsi que 2 poussoirs sur RA2 et 3 .
Par contre je nai pas isolé les pin iscp dat et clock du reste du circuit .... j’espere avoire un peu eclairer ta lantene sur mon probleme moi je suis a deux doigt de tout envoye ch..

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#4 Message par Guigui02 » mar. 29 mai 2018 21:26

Paulfjujo si jamais tu as sous la main un schema simple et fiable pour les connections icsp entre pic et pickit 3 je suis preneur car je pense que sa peu venir de la et aussi comment peut on utiliser les port pgd et pgc du pic même avec l’icsp de raccordé tu parle de les isolé comment ? Merci

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#5 Message par Guigui02 » mar. 29 mai 2018 22:21

Image
Voila le shema exact :-D

pickit 3
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 850
Enregistré en : juillet 2016
Localisation : Terre

#6 Message par Temps-x » mer. 30 mai 2018 01:17

Bonsoir Guigui02, paulfjujo, et tout le forum,

J'ai exactement le même problème que toi, mon Pickit3 fonctionner bien au début, mais après quelle que jour d'utilisation
il ne voulais plus programmer les Pics, est pourtant j'avais rien de branché dessus, juste les fils de programmation.

étant méfiant j'ai remplacé le pic par un neuf, même chose.

Je suis revenu a mon ancien programmeur JDM, qui lui a réussi la programmation des Pic que mon Pickit3 n'arrivais pas à faire.

Je pense qu'il doit y avoir un circuit défectueux sur certain clone du Pickit3(chinois), je vais l'examiner, et voir si un circuit ne serait
pas en cause.

Dommage que se post n'est pas était mis à la suite soucis avec PicKit 3 qui se trouve ICI

C'est vraiment pas plaisant de faire de la programmation quand on passe tout son temps, à essayer de programmer son Pic. :mad:

Ps : J'ai avancé dans ton programme, mais par manque de temps, et de fatigue, j'ai mis de côté. :wink:

==> A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#7 Message par Guigui02 » mer. 30 mai 2018 09:24

Salut tout le monde , desolé j’ai pas fait gaff pour l’autre post :roll: .
Sinon oui c’est vraiment deplaisant de passe ses soirees a galerer avec ce programmateur :cry:
Pour le programme t’inquiete pas tempx de toute facon je ne peux rien programmer la carte avec ce pic deconñe aussi je pense aussi que mon pickit3 clone est la cause je vais regarder pour acheter autre chose des idées a pas cher ? Je vais regarder jdm a plus

pickit 3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1019
Âge : 67
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#8 Message par paulfjujo » mer. 30 mai 2018 09:45

bonjour à tous,


* ATTENTION :
sur certain PIC la programmation en mode basse tension (5V) implique la pin RB3 /PGM qui doit etre reliée au 0V
le seul moyen de revenir en arriere est de le reprogrammer en mode High level

sur ton schema , on ne voit pas les 7 segm de ton port B , puisque RB7 RB6 sont seules sur ICSP !
il suffit de rajouter 2 cavalier sur RB7 et RB6 pour isoler les elements externes connectés dessus

Image1.jpg
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

pickit 3
Guigui02
Débutant
Débutant
Messages : 42
Enregistré en : mars 2017

#9 Message par Guigui02 » mer. 30 mai 2018 09:51

Ok je vais essayer deja sans utiliser le portb et si je l’uilise je mettrais des cavaliers le probleme c’est que du coup a chaque programmation il faut replacr les cavaliers c’est un peut embetant...
Pour la programmation en basse tension ou hight level je ne sais pas comment faire ou se trouve l’ption dans mplab ?
Merci

pickit 3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1019
Âge : 67
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#10 Message par paulfjujo » mer. 30 mai 2018 10:20

Guigui02 a écrit : le probleme c’est que du coup a chaque programmation il faut replacer les cavaliers c’est un peut embetant...


tu peux aussi mettre un double dipswitch inverseur !
sinon, c'est pas la mer à boire...!

:!!: Attention aussi au contraire,
si on laisse le PIC ICSP connecté ,avec les connections "Application"
ou si on laisse le PIckit connecté .. HORS tension ( liaison USB deconnectée)

:!!: Attention aussi au fait que la masse metalique du cordon USB est aussi à la masse du PC
qui est retransmis au 0V du PIC par la liaison pin3 ICSP 0V Gnd
On peut se retrouver avec des potentiels par rapport à la terre ! ( 10 à 30V AC mesuré , heureusement sous haute impedance!)
ou , probleme vecu, si je connecte mon oscillo Tektronics , avec masse coté +VCC => court-jus de l'alim via quelques ohms ..
(limitation par la resistance du cable USB)
On peut donc claquer un circuit CMOS sensible.. en mettant le doigt dessus.

Pour la programmation en basse tension ou hight level je ne sais pas comment faire ou se trouve l’option dans mplab ?
Merci


MPLAB , je sais pas ..
Mikroc : dans la config bit projet "Low voltage Programming"

:!!: et lire aussi la datasheet dur PIC !


Retourner vers « Langage ASM »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité